[WARdrobe] Search and AddOn Updates

Posted: October 14, 2010 in WARdrobe

I pushed up a new version of the site last evening.  Some of the new features include:

  • Updated Nav Bar – Added an “About” section which contains news, FAQ and my “to-do” list.If you notice anything not on the list, please let me know.
  • Updated AddOn – We’re up to Version 1.5 now.  Version 1.5 fixes the cross-language issue that was polluting the database.  Essentially, if someone was on a German server, and had their language set to English, the tooltips were a hybrid.  Same goes for German on an English Server.  I’ve got a little bit of cleanup to do, but it won’t be insane.
  • Search Bar – This is a basic search, nothing elaborate.  It can be found at the top right of every page.  Simply start typing and the bar will snag the first 25 matches.  Give it a whirl and let me know.
  • Item Set Issues – There’s no fix in yet, but I’m aware that some item sets are blowing up when you try to view them.  This is hot on my list to get fixed.  Preferably before the weekend.
  • Zealot Spec Template– Apparently, I had Zealots set to use a Staff.  This has been switched out to a Mainhand/Offhand layout.
  • Database Indices – This isn’t something to see, but should help performance across the site.  If you notice any pages that are inherently slow, let me know.

If you notice anything funky, please let me know!

On a side note, we’ve passed the 13,000 unique item mark.  Pat, you’re a beast.  Beast!

The top five contributors are:

  1. Patriot52 – 7,403 Items
  2. Lokax – 5,165 Items
  3. Serapis – 4,302 Items
  4. Rhonx – 3,711 Items
  5. Moddion – 2,719 Items

Rock on, guys and gals!

Advertisements
Comments
  1. Rikker says:

    I’ll post on the site too, but before I forget:

    Could you take a look at the issue of the log file being full when WAR is reopened?
    (I forgot to upload after I logged one night.)

    When that happens, I get in-game messages (presumably intended) that it needs me to roll-over the items already in the database again. It’s a bit annoying, as it clutters chat. Nothing super-high priority though.

    • Rancid says:

      Actually, the log files are cleared every time you start WAR and log in a character. (They’re not cleared by simply logging one toon out and logging another in.)

      The Re-Hover message you’re seeing is a bug in Mythic’s UI that I have to code around. Each Item has a possible ItemSetId that is set. When that value is set, you can call another function in the UI to get the full details of that Item Set. Unfortunately, sometimes when you first hover over an item, the second call to get the details won’t return anything. A subsequent hover will produce the data I need to log. I do this, so I don’t have any incomplete data saved to the log file.

      When I learn more LUA, I intend on putting in some config values to allow you to control the verbosity of the logging as it pertains to the chat window. That’s kinda far down on my list, though. :-/

      • Rikker says:

        I gotcha. Probably should have actually verified it before I complained, huh? ;P.

        It doesn’t seem to happen if I upload to the site before reopening WAR, though that may just be me being lucky?

        Either way, thanks for the response! I understand it’s far down the list, certainly. Unfortunately, my knowledge of LUA is mostly limited to small tweaks to existing programs, so I can’t help you out, or I’d do it and send you the file for verification. I still might… I’m slowly learning more as I look at these add-ons. We’ll see how bored I get.

        Either way, thanks a ton, and keep up the good work!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s